• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

[Résolu] Passer du mpg en divx

Djulebox

Nouveau membre
21 Septembre 2005
23
0
39
Bonjour à tous,

Je suis nouveau sur le site et j'utilise un mac depuis quelques mois et autant dire que je suis un peu paumé par rapport au PC sur les logiciels vidéos pour retoucher des fichiers, les enregistrer dans d'autres formats etc.

Le souci que je rencontre là maintenant, c'est que j'ai acheté un adapateur TNT Terratec pour mon G5 et que le format d'enregistrement est le mpeg (pas possible d'enregistrer dans un autre format).

Pour un film d'1h, c'est 2 go de données, je préfèrerais pouvoir encoder les vidéo mpg en divx et (accessoirement ;)) couper les bandes noires horizontales et verticales qui entourent l'image.

Y a-t-il une bonne âme pour m'indiquer le chemin à suivre?

Jusqu'à présent pour transformer mes vidéos d'un format à un autre je me débrouillais avec la fonction d'export vidéo de Toast Titanium 7 mais il ne prend pas en charge le mpg...

Nota bene : mac ç'est génial, je suis hyper heureux d'avoir switché!

Merci
 

woulf

Membre d’élite
Club MacG
12 Décembre 2001
4 146
345
Alors d'abord tu vérifies que tu as bien installé les codecs divX (5.2.1 il me semble pour le dernier gratuit avant le 6 qui est payant), ensuite tu télécharges:

- D-Vision 2
- D-Vision 3
- Handbrake

Dans les trois il y en a au moins un qui te permettra de faire ce que tu veux, et l'auteur de D-Vision vient par ici des fois, ses softs sont tout bonnement excellents !
De mémoire D-Vision 3 ne prend plus en compte les .mpg mais les Video_Ts (mais ça fait un ptit moment que je n'ai plus encodé comme ça, depuis que eyetv et toast travaillent en super synergie pour faire du divX et me le graver ;)
 

Djulebox

Nouveau membre
21 Septembre 2005
23
0
39
Je peux pas utiliser ces versions de D-vision parce que j'ai Tiger et je crois que ces versions ne sont pas compatibles. Si tu me dis ques les versions ultérieures ne gèrent pas le mpeg, je vais pas pouvoir régler mon problème comme ça.

Tu me parlais d'Handbrake aussi, il n'encode pas que les dvd?

Pour le format exact du mpeg, j'avoue mon ignorance entre les différents formats mpeg. Tout ce que je sais c'est qu'il fait environ 2go par heure...
 

woulf

Membre d’élite
Club MacG
12 Décembre 2001
4 146
345
Djulebox a dit:
Je peux pas utiliser ces versions de D-vision parce que j'ai Tiger et je crois que ces versions ne sont pas compatibles. Si tu me dis ques les versions ultérieures ne gèrent pas le mpeg, je vais pas pouvoir régler mon problème comme ça.

Tu me parlais d'Handbrake aussi, il n'encode pas que les dvd?

Pour le format exact du mpeg, j'avoue mon ignorance entre les différents formats mpeg. Tout ce que je sais c'est qu'il fait environ 2go par heure...
J'ai tiger et DVision 2 et 3, pas de problèmes.
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Télécharge aussi ffmpegX, installe le soigneusement (explications sur la même page), lis un peu du tuto en ligne de temps en temps si tu cherches à affiner: non seulement il fera 100% de ce que tu veux, mais il te servira aussi à d'autres changements de formats et/ou compression ultérieurs.
 

Djulebox

Nouveau membre
21 Septembre 2005
23
0
39
Super! Je vais essayer ffmpeg, parce que D vision n'arrive pas à convertir mon fichier mpg en avi.

Le mpg en question est bien du mpeg 2 selon ce qui est écrit sur la boîte de mon décodeur enrgitreur TNT. Ce qui est bizarre, c'est que Tiger me dit que cest du "multiplexed mpeg 1/2", alors que D-vision me dit que c'est du mpeg 1...

J'ai donc essayé de convertir mon fichier hier soir avec D-Vision 3 mais le typer de fichier doit être particulier car le logiciel n'arrive pas à déterminer les caractéristiques de la vidéo.

Il me dit :
- que c'est du mpeg 1
- que les dimensions de l'image sont de 0*0 (ce qui n'est bien sûr pas le cas)
- que le débit de données, le nombre de frames, le codec etc. sont indéterminés

Quand je lui demende de le convertir en avi, il lance la tâche, 1 seconde après il me dit qu'elle est achevée alors qu'il n'a enregistré aucun fichier!

Bizarre, parce que j'ai réussi sans problème avec le même logiciel à encoder un autre mpeg, que je n'ai pas enregistré avec mon adaptateur/enregistreur TNT.

Peut-être le format d'enregistrement de l'adaptateur TNT est-il particulier, qu'en pensez-vous?
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Ce qui est bizarre, c'est que Tiger me dit que cest du "multiplexed mpeg 1/2", alors que D-vision me dit que c'est du mpeg 1...
Ils disent donc la même chose: Tiger s'en fout que le mpeg soit 1 ou 2 quand il est multiplexé (c'est ce que je comprends, moi j'ai panther) et D-Vision dit que c'est du mpeg1

Il me dit :
- que c'est du mpeg 1
- que les dimensions de l'image sont de 0*0 (ce qui n'est bien sûr pas le cas)
- que le débit de données, le nombre de frames, le codec etc. sont indéterminés

Quand je lui demende de le convertir en avi, il lance la tâche, 1 seconde après il me dit qu'elle est achevée alors qu'il n'a enregistré aucun fichier!

Bizarre, parce que j'ai réussi sans problème avec le même logiciel à encoder un autre mpeg, que je n'ai pas enregistré avec mon adaptateur/enregistreur TNT.

Peut-être le format d'enregistrement de l'adaptateur TNT est-il particulier, qu'en pensez-vous?
J'en pense que D-Vision est très bien. Je pense aussi que sur ce coup là, il y a un problème pour déterminer l'entête du fichier, mais dur à dire de loin. Peut-être faudra-t-il démuxer 1 piste audio et 1 video avant de poursuivre. Mais le mieux est déjà de savoir le format exact de ce fichier.
Pour le reste, je t'ai donné une solution.
 

woulf

Membre d’élite
Club MacG
12 Décembre 2001
4 146
345
Vu que le format a l'air d'être atypique, c'est sans doute effectivement ffmpegX qui s'en sortira le mieux ;)
 

Djulebox

Nouveau membre
21 Septembre 2005
23
0
39
Enigme toujours pas résolue :mad:

FFmpeg non plus n'arrive pas à percer le mystère de ce mpeg récalcitrant : comme D-vision il n'arrive pas afficher les caractéristiques de la vidéo : les dimensions de l'image, le framerate, le bitrate... Il arrive encore moins à l'encoder en divx.

Voyez-vous une explication et une solution? Je suis perdu...
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Fat Boss Slim a dit:
Arrives-tu quand même à la lire ?

Si oui alors cherche les infos via l'appli qui le lit...
Mais bien sûr... il faut que tu l'ouvres avec ce que tu veux (peux) pour voir les informations des pistes. Tu sais ce que c'est, quand même, ce film... Essaie VLC ou MPlayer, et cherche les infos concernant les pistes audio et video. Sans ça, pas d'idée sur le soft approprié à utiliser.
 

Djulebox

Nouveau membre
21 Septembre 2005
23
0
39
Bon, ça y est ç marche j'ai réussi à encoder cette satanée vidéo!

En fait, il s'agissait d'un bug....de ma part puisqu'il manquait un élément (et pas des moindres) à ffmpeg pour l'encoder : mpeg2enc...!!

Malheureusement, mes soucis ne sont pas terminés, car s'il encode la vidéo sans problème, ffmpeg refuse de m'encoder le son.

Quand je regarde les informations de ffmpeg sur le processus d'encodage, je lis "no audio", alors qu'il y en a bel et bien une, de piste audio...

Ce qui est bizarre, c'est que quand je règle la partie audio avant d'encoder, je lui indique qu'il faut encoder la piste 0 et quand il a terminé d'encoder et que je reviens dans les réglages audio pour comprendre ce qui ne fonctionne pas, je remarque qu'il est calé sur "piste 01". S'il a encodé cette piste, normal qu'il ne trouve pas de son!

Comment puis-je faire?
Quand je lui demande d'extraire en mp3 le son du film, ffmpeg y arrive très bien, mais quand j'ajoute la piste audio à la piste vidéo avec D vision, il y a un décalage dans le son que je ne sais pas régler (sur mac, sur PC je sais faire)...

Merci encore pour votre aide!
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Pfff... Le pb, c'est que tu fonces tête baissée (pourtant je t'ai dit de regarder la page pour l'install) et en plus tu ne réponds pas aux questions posées (2 fois par moi, 1 fois par FBS)... ça serait peut-être déjà résolu: AS-TU REGARDÉ DANS VLC (pomme + i) ET QUEL EST LE FORMAT EXACT DE CE FICHIER ?

Ensuite, quand tu as ouvert ffmpeg, tu a mis ton fichier mpeg coté "source", que s'est-il passé ?
Normalement, il doit te dire dans video:mpeg 1 + taille + bitrate + fps et audio: mp2 + 44100 + 128 par exemple. Ok, non ? ou autre chose à signaler (pas dans 4 posts ;))

mais quand j'ajoute la piste audio à la piste vidéo avec D vision, il y a un décalage dans le son que je ne sais pas régler
Tu n'as pas besoin de démuxer pour remuxer après. Si tu tiens à le faire, dans ffmpeg, c'est dans outils (dernier onglet) > mux...
 

Djulebox

Nouveau membre
21 Septembre 2005
23
0
39
J'ai regardé le format dans VLC samalaplaya, je te mets les caractéristiques du fichier ci-dessous :

Flux O
Codec=mpgv
Type=vudéo

Flux 1
Codec=mpga
langue=français
type=audio

Flux 2
Codec=a52
Langue=français
type=audio

Comme je te l'ai dit, ffmpeg encode la vidéo en divx sans problème mais zappe la piste audio, je me retouve avec une vidéo sans son. Sais-tu comment je peux remédier à ce problème?

C'est pour résoudre ce souci que j'ai demandé à ffmpeg d'extraire le son du fichier mpeg et de l'encoder en mp3, pour ensuite l'ajouter avec D Vision au fichier divx de ffmpeg.

Là, nouveau problème : il y a un décalage entre le son et l'image et je ne sais pas quel logiciel utiliser pour décaler le démarrage de la piste audio par rapport à la vidéo.

Dis-moi si tu veux d'autres précisions et désolé de foncer tête baissée...
 

Ludopac

Membre émérite
5 Avril 2001
970
4
37
Nancy
www.objectifmac.com
A mon avis, ton fichier ne possède pas la bonne extension. Ce n'est pas un fichier .mpg mais un fichier .vob.

En tout cas, c'est ce que je conclue des infos données par VLC :

- plusieurs pistes audio
- une piste en AC3
 

Djulebox

Nouveau membre
21 Septembre 2005
23
0
39
S'il y a plusieurs pistes audio, c'est très surprenant pusique j'enregistre la vidéo depuis un adaptateur TNT, a priori il n'y a qu'une langue : le français :)

Le problème n'est pas tant la vidéo, puisque ffmpeg réussit à l'encoder, mais de réussir à comprendre pourquoi ffmpeg zappe la piste audio lors de l'encodage, alors qu'il arrive très bien à extraire l'audio quand j'effectue cette tâche séparément de l'encodage vidéo...
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Djulebox a dit:
S'il y a plusieurs pistes audio, c'est très surprenant pusique j'enregistre la vidéo depuis un adaptateur TNT, a priori il n'y a qu'une langue : le français :)

Le problème n'est pas tant la vidéo, puisque ffmpeg réussit à l'encoder, mais de réussir à comprendre pourquoi ffmpeg zappe la piste audio lors de l'encodage, alors qu'il arrive très bien à extraire l'audio quand j'effectue cette tâche séparément de l'encodage vidéo...
Nan, mais ce que veut dire Ludo, c'est que ce n'est pas du mpeg1 ou tu aurais dans les infos:
Flux O
Codec=mpgv
Type=vidéo

Flux 1
Codec=mpga
langue=français
type=audio

Là, y'en plus le a52 qui est un format de son contenu sur les DVD... ça n'a rien à voir avec la langue.
Comme je te l'ai dit, ffmpeg encode la vidéo en divx sans problème mais zappe la piste audio
Donc il ne fait pas un divx sans problème, un divx sans pb contient une piste audio en mp3 ;)
Là, nouveau problème : il y a un décalage entre le son et l'image et je ne sais pas quel logiciel utiliser pour décaler le démarrage de la piste audio par rapport à la vidéo.
Sur D-Vision je ne sais pas (mais Ludo pourra peut-être te le dire), dans ffmpeg > Outils > Mux il y a en bas une fenêtre "Sync" ou tu peux rentrer des paramètres de retard d'une piste ou de l'autre...

Dis-moi si tu veux d'autres précisions et désolé de foncer tête baissée...
Tu n'as pas à être désolé, un truc te titille et tu le dis... Mais les questions ne sont pas toujours anodines, donc... on pourrait juste avancer plus vite, sans plus... donc rien de grave ;)
Par exemple, j'aimerais en savoir plus sur
Ensuite, quand tu as ouvert ffmpeg, tu a mis ton fichier mpeg coté "source", que s'est-il passé ?
pour en avoir le coeur net.
De toutes façons, un mpeg1 n'a pas 3 pistes, ça c'est sur...
 

Djulebox

Nouveau membre
21 Septembre 2005
23
0
39
J'ai des infos qui vous permettrons certainement d'y voir plus clair.

1 - Comme tu me l'as demandé, ce que m'affiche ffmpeg quand je mets le fichier côté "source" :

de : mpg
vidéo : mpeg-2, 720x576, 15 000 kbps, 25 fps
audio : ac3, 48 000 Hz, 384 kbs

2 - Les informations fournies par ffmpeg sur le déroulement de l'encodage de la vidéo

Encoding started on Tue Sep 27 20:29:49 CEST 2005
MEncoder dev-CVS-050814-13:46-3.3 (C) 2000-2005 MPlayer Team
Mac OSX static build for ffmpegX
AltiVec found
CPU: PowerPC
success: format: 0 data: 0x0 - 0x4ea5e7f8
TS file format detected.
DEMUX OPEN, AUDIO_ID: 0, VIDEO_ID: -1, SUBTITLE_ID: -1,
PROBING UP TO 2000000, PROG: 0
VIDEO MPEG2(pid=120)NO AUDIO! NO SUBS (yet)! PROGRAM N. 0
Opened TS demuxer, audio: ffffffff(pid 0), video: 10000002(pid 120)...POS=0
VIDEO: MPEG2 720x576 (aspect 2) 25.000 fps 15000.0 kbps (1875.0 kbyte/s)
[V] filefmt:29 fourcc:0x10000002 size:720x576 fps:25.00 ftime:=0.0400
xvid: using library version 1.1.-125 (build xvid-1.1.0-beta2)
Opening video filter: [expand osd=1]
The selected video_out device is incompatible with this codec.
Also try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [scale w=624 h=272]
Crop: 716 x 330, 4 ; 126
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
Writing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
VDec: vo config request - 720 x 576 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
SwScaler: reducing / aligning filtersize 2 -> 2
SwScaler: reducing / aligning filtersize 2 -> 2
SwScaler: reducing / aligning filtersize 2 -> 2
SwScaler: reducing / aligning filtersize 2 -> 2
SwScaler: FAST_BILINEAR scaler, from Planar YV12 to Planar YV12 using AltiVec
videocodec: XviD (624x272 fourcc=44495658 [DIVX])
xvid: par=0/0 (vga11), displayed=628x272, sampled=624x272
xvid: CBR Rate Control -- bitrate=953kbit/s
1 duplicate frame(s)!
ODML: vprp aspect is 16384:7096.
ODML: vprp aspect is 16384:7096.
1 duplicate frame(s)!
TS_PARSE: COULDN'T SYNC
Flushing video frames
Writing AVI index...
Fixing AVI header...
ODML: vprp aspect is 16384:7096.
Video stream: 890.835 kbit/s (111354 bps) size: 261201848 bytes 2345.680 secs 58642 frames
Encoding completed on Tue Sep 27 21:25:55 CEST 2005


Pour moi c'est un peu du chinois je dois dire mais peut-êtr que ça vous parlera!